
Lab 3.1: Using Internet Assistant for Word
Lab Overview
Objectives
After completing this lab, you will be able to:

 Install the Internet Assistant for Word.
 Create a Web page with the following items: 

 Bold, italic, and quoted text
 Bulleted lists
 Links to HTML files, Office documents, internal bookmarks, e-mail, and newsgroups
 Graphics
 Tables
 Animations

 Convert an Office document to HTML format.

Scenario
For the remainder of the labs in this course, you will be creating a Web site for a fictitious company, Main
Street Market. Main Street Market wants to publish existing Office documents, provide access to 
information in databases, and provide a way for customers to view their product price lists and select 
items to purchase.

In this lab, you will enhance the home page for the Main Street Market Web site, using Internet Assistant
for Microsoft Word. You will format text, add graphics, add links to HTML files and other Office 
documents, and convert an existing document to HTML. You will view the results of all your work with the
Internet Explorer.

Lab Setup
You are provided with a simple home page and Microsoft Office files in the \Labs\Lab03.1 directory. 

If you need help, the solutions for all of the exercises in this lab can be found in the \Labs\Lab03.1\
Solution directory. 

This demonstration shows the solution to this lab.

 

Estimated time to complete this lab: 120 minutes.

Exercises
The following exercises provide practice working with the concepts and techniques covered in this 
chapter.

Exercise 1: Installing Internet Assistant for Word
In this exercise, you will install the Internet Assistant for Word and view the source HTML of a simple 
Web page.

Exercise 2: Formatting Text and Graphics
In this exercise, you will add HTML components to Web pages in the Main Street Market site. You will 
format text, add graphics, set background colors and images, and add a video.
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Exercise 3: Adding Links
In this exercise, you will add links to Web pages, Microsoft Office documents, and other Internet 
services, such as e-mail, newsgroups, and software download sites.

Exercise 4: Converting a Microsoft Word Document
In this exercise, you will use the Internet Assistant for Microsoft Word to convert a document from Word 
format to HTML format. Then, you will add bookmark links to make it easier to navigate within the page.

Optional Exercise: Converting Microsoft Office Information
In this exercise, you will use the Internet Assistants for Microsoft Excel and Microsoft Access to convert 
information to HTML format.

Exercise 1: Installing Internet Assistant for Word
You can create HTML files with any ASCII-based text editor. However, you might find it easier to use an 
authoring tool, such as Internet Assistant for Word. In this exercise, you will install Internet Assistant for 
Word, view the source of a simple HTML file, and make some minor revisions.

 Install the Internet Assistant for Microsoft Word 
1. Run the setup program for the Internet Assistant for Microsoft Word from this compact disc.

 
2. Or, go to the Authoring Software page on the Microsoft Web site and install from there. 

http://www.microsoft.com/workshop/author 
a. Follow the links to the Download area for Internet Assistant for Microsoft Word for the version of 

Microsoft Word you own.
b. Click the link to download the Internet Assistant files.
c. Copy the self-extracting file to a temporary subdirectory on your system's hard disk. 
d. In Windows Explorer, double-click the self-extracting file. After the file expands, Setup will begin 

automatically. 
3. Follow the setup instructions. 

 View the source HTML of a simple Web page
1. Copy the file default.htm from the \LABS\LAB03.1 directory to your root directory of your Web site.

This creates the home page of this Web site.
2. From the Internet Explorer, open the home page for your Web site by entering the URL of your 

Internet Server in the Address field.

Note To test HTML documents you create, you do not need to place them on an Internet server. You 
can open a local HTML file in the Internet Explorer with the Open command on the File menu, or by 
selecting the file in the Windows Explorer and choosing Open on the File menu. In this manner, you 
can test all the functionality contained within the HTML file. When you want to publish your files 
externally, place them on an Internet server.

3. To view the HTML for this document, choose Source from the View menu in Internet Explorer.
The Internet Explorer creates a temporary .htm file, and opens it in Notepad.

4. Close the file in Notepad.
5. In Windows Explorer, edit the file default.htm by right-clicking it and selecting Edit from the shortcut 

menu. This starts Internet Assistant for Microsoft Word. 
Internet Assistant opens in Edit mode, where you can edit the HTML document. As you add elements 
to the document, Internet Assistant is actually adding HTML tags and then interpreting them for you.
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6. To view the HTML for this document, choose HTML Source from the View menu.
You are looking at the actual HTML tags that make up this file. If you edit the tags here, the file will 
look different when you return to Edit mode.
Notice that the HTML source is displayed slightly differently than in Notepad, but the contents are the 
same.

7. Click the Auto Format HTML button on the HTML toolbar. 
This formats the HTML in different colors and font styles so that it is easier to read and edit.

8. Switch back to Edit mode by selecting the Return to Edit Mode button on the HTML toolbar.
9. Add a line to the bottom of the file: Last Changed: <insert today's date>

10. Save the changes to the file default.htm.
11. Return to Internet Explorer and select Refresh. Notice the new line of text that you added.

Exercise 2: Formatting Text and Graphics
In this exercise, you’ll edit the home page for the Main Street Market. You’ll add a background image 
and color, add graphics, format text, and add a video.

 Add a background image and background color
1. In Lab 2.2, you created an Images directory in the root directory of the Main Street Market Web site 

and copied GIF files into it. If you didn't, create the directory now, and copy the GIF file, Marble.gif, 
from the \Labs\Lab03.1 directory to the Images directory of your Web site.

2. Open the home page for the Main Street Market, default.htm, with Internet Assistant for Word.
3. Set the background image and color:

a. Choose Background and Links from the Format menu.
b. Set the Image field to "Images/Marble.gif".
c. Set the background color to white.

4. Save your changes and view the new background image on the Main Street Market home page with 
Internet Explorer.

 Format the text on the Main Street Market home page
1. Format the title text, "Main Street Market": 

a. Center the text.
b. Use a different font style, such as Arial, and make it bold and larger.

2. Italicize each mention of "Main Street Market" in the text body.
3. Convert the list of benefits for customers shopping on the Internet into a bulleted list.
4. Center the line at the bottom of the page that contains the names of other pages in the Main Street 

Market Web site, and make it a smaller font size.
5. Indent the signature of the President by creating a table:

a. Select the four lines of text that are the signature of the President of Main Street Market.
b. Select "Convert Text to Table" from the Table menu and create a table with two columns, 

separating entries with a paragraph mark.
c. Move the lines into the second column.
d. Adjust the width of the first column to a proper indentation.

6. Save your changes and view the Main Street Market home page with Internet Explorer.
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Your finished page should look something like this: 

 Add graphics and a table to the Main Street Market home page
1. Make sure that the GIF files MSMLogo.gif, Welcome.gif, Book.gif, QA.gif, Grocery.gif, Form.gif, and 

Employee.gif are in the Images directory of the Main Street Market Web site. If they aren't, copy them
from the \Labs\Lab03.1 directory to the Images directory of your Web site.

2. Replace the text “Main Street Market” at the top of the page with a graphic of the company logo, 
MSMLogo.gif.

3. Place the Welcome GIF, Welcome.gif, next to the company logo.
The two images look like this: 
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4. Add graphics down the left side of the page:
a. Add four more rows to the top of the table that contains the President's signature by choosing 

Insert Rows from the Table menu.
b. Move each of the first four paragraphs of text into the second column of the four new rows in the 

table. 
You should now have a table with two columns and five rows, with text in the second column of 
each row.

c. Choose Cell Width and Spacing from the Table menu; deselect WYSIWYG, and select 
"Automatically sized." 

d. Place the five GIF files, Book.gif, QA.gif, Grocery.gif, Form.gif, and Employee.gif, in the cells of the 
first column in the table.

5. Save your changes and view the Main Street Market home page with Internet Explorer.
The finished table with images should look something like this: 

 Add a video to the Main Street Market home page
1. Copy the video file, Welcome.avi, from the \Labs\Lab03.1 directory, to the root of your Web site.
2. Split the last row of the table on your home page into three cells, such that the third column is blank:

a. Select the second column in the last row of the table.
b. Select Split Cells from the Table menu, and enter 2 for the number of columns to split the cell into.

3. Insert the Welcome.avi video into the third column of the last row and set it to play when the mouse 
moves over it:
a. Select the third column in the last row of the table.
b. Select Picture from the Insert menu, and fill in the information on the Video tab.
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4. Save your changes and view the Main Street Market home page with Internet Explorer.
The finished table with the video should look something like this: 

Exercise 3: Adding Links
The power of the World Wide Web lies in the existence of links between HTML and other documents. 
For example, it is common for each of your Web pages to have links to the other pages of your Web site.
This provides your readers an easy way to navigate your site. 

In this exercise, you will add links to HTML pages, Office documents, and other Internet services from 
the Main Street Market home page.

 Edit the Main Street Market home page
 If it is not already open, open the home page for the Main Street Market, default.htm, with Internet 

Assistant for Word.

 Add links to other Web pages
1. Copy the files CustData.htm and EmpOnly.htm from the \Labs\Lab03.1 directory to the root of the 

Main Street Market Web site.
2. At the bottom of the Main Street Market home page, locate the list of pages in this site. It looks like 

this:

3. Add a hyperlink from the text "Customer Data" to the CustData.htm Web page:
a. Select the text “Customer Data”. 
b. Click the Hyperlink button on the Formatting toolbar, or choose HyperLink from the Insert menu.

Notice that the selected text is entered in the Text to Display field of the Hyperlink dialog box.
c. Enter the filename, CustData.htm, and choose OK.

Notice that the text is now blue and underlined, indicating that the text is a hyperlink.
4. View the HTML source of the home page and find the link you just added.

Look for <A> and </A> tags.
5. Repeat this process for the text "Employees Only", linking it to EmpOnly.htm.
6. Save the changes to the file.
7. Open Internet Explorer, go to the Main Street Market Web site, choose Refresh, and test the links.

 Add a link to an Office document
1. Copy the file MainSt.xls from the \Labs\Lab03.1 directory to the root of the Main Street Market Web 

site. 
2. Link the text “Company Information” in default.htm to the file MainSt.xls in the same directory.
3. Save the changes to the home page.
4. In Internet Explorer, choose Refresh and test the link you created. 

Notice that the page is displayed in Internet Explorer as if it were a Web page.
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 Add links from graphics
1. Set the border of each image in the table comprising the body of the Main Street Market home page 

to zero:
a. Edit the image's properties by selecting the image and then choosing Picture from the Insert menu.
b. On the Options tab, check the Display Border check box, and set the Border Size to zero.

2. Link the five images to the pages of the Main Street Market Web site as indicated in the table below:

Image File Link location

Book.gif MainSt.xls
qa.gif QA.htm
Grocery.gif Products.htm
Form.gif CustData.htm
Employee.gif EmpOnly.htm

Note  You will be adding the files QA.htm and Products.htm to the Main Street Market Web site in 
later exercises.

3. Save the changes to the home page.
4. In Internet Explorer, choose Refresh and test the links you created. 

 Add links to Internet services
You can also add links from an HTML to other Internet services, such as mail, newsgroups, and sites for 
downloading software.

1. In the Main Street Market home page, add a link to your own e-mail account from the text 
"owner@MainStMarket.com".

Tip  To link to an email address, set the URL to mailto: followed by the email address.

2. Add a link to the alt.cooking-chat newsgroup from the text "alt.cooking-chat".

Tip  To link to a newsgroup, set the URL to news: followed by the name of the newsgroup.

3. Save your changes to the home page.
4. In Internet Explorer, select Refresh and test the e-mail and newsgroup links.

Note These links will only work if you are connected to the Internet. To send e-mail, you need to have an
e-mail application installed. To read a newsgroup, you need access to a news server.

 Add a link to a download site
1. Make sure that the GIF file, BestWith.gif, is in the \Images directory of the Main Street Market Web 

site. If it isn't, copy it from the \Labs\Lab03.1 directory to the \Images directory of your Web site.
2. Insert the BestWith.gif image in the lower-left corner of the Main Street Market home page.
3. Link the image to the downloadable executable file for Internet Explorer, at either the FTP site or the 

HTTP site, http://www.microsoft.com/ie/ie.htm.
4. Save the changes to the file.
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5. In Internet Explorer, choose Refresh and test the download link.

Note This link will only work if you are connected to the Internet. 

Exercise 4: Converting a Microsoft Word Document
In this exercise, you'll work with a list of Frequently Asked Questions that Main Street Market wants to 
publish on the Web site.

Instead of just linking to the document in its current format, you will convert it to HTML format and then 
add a link to it from the home page. Then, you will create bookmarks and internal links to make browsing
the document easier for your readers.

 Convert a Microsoft Word document to HTML format
1. Open the Question and Answer document, QA.doc, in the \LABS\LAB03.1 directory.
2. Save the document as an HTML file, QA.htm, in the root directory of your Web site.
3. Close the converted file.

 Add a link to the converted document from the Main Street Market home page
1. Edit the Main Street Market home page, default.htm, with Internet Assistant for Word.
2. Locate the text "Q&A" at the bottom of the document.
3. Link the text “Q&A” to the file you just converted, QA.htm, in the same directory.
4. Save changes to your home page.
5. Run Internet Explorer and open the home page of the Main Street Market Web site. Test the link to 

the converted Frequently Asked Questions document.

 Add bookmark links
1. In the Frequently Asked Questions page, QA.htm, add a bookmark to the beginning of each answer 

section:
a. Select some text at the top of the answer section.
b. Choose Bookmark from the Edit menu, or click the Bookmark button on the Formatting toolbar.
c. Type a name for the bookmark, and choose Add.

2. Add links from each question at the top of the document to the corresponding answer bookmark.
3. Add a bookmark to the top of the Question & Answer page.
4. Add text, "Return to top", to each answer section, and link it to the bookmark at the beginning of the 

page.
5. Save your changes to the Q&A file.
6. Run Internet Explorer and open the Frequently Asked Questions page of the Main Street Market Web 

site. Test the bookmark links. 
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Optional Exercise: Converting Microsoft Office Information
This exercise requires Microsoft Access 95 and Microsoft Excel 95.

The products sold by Main Street Market are kept in a table in the MainSt database. There is also a 
spreadsheet used by the employees to keep track of the most popular products. The Internet Assistants 
for Microsoft Access and Microsoft Excel can convert this information into Web pages that can be 
published on the Main Street Market Web site. 

If You Have Microsoft Access
Publishing information from Microsoft Access is different than from the other Office products. The 
Access Internet Wizard takes a snapshot of the information at a point in time, and converts it into HTML. 
Because the information in the Web page is static, each time the information in the database changes, 
you need to run the Internet Assistant for Access again to create a new Web page with the updated 
information.

 Convert a database table to HTML using the Internet Assistant for Microsoft Access
1. Run Setup for the Internet Assistant for Microsoft Access from this CD.

 
2. Or, using Internet Explorer, go to the Authoring Software page on the Microsoft Web site, and follow 

the links to the download site for the Internet Assistant for Microsoft Access. 
http://www.microsoft.com/workshop/author
a. Download the Internet Assistant and follow the directions to install it.

3. Start Microsoft Access and open the MainSt.mdb database in the \Labs directory.
4. Choose Add-Ins from the Tools menu, and select Internet Assistant.
5. Follow the steps of the Internet Wizard to create a Web page from the Products table in the MainSt 

database:
a. Select the Products table.
b. Don't use a template.
c. Save the resulting HTML file in the root directory of your Web site. Internet Assistant for Access 

names the HTML file from the table used to build it. The filename should be Products.htm. 
6. Edit your home page to link to this new HTML file, Products.htm, from the text "Products" at the 

bottom of the page.
7. Save and test the new link with Internet Explorer.

Notice that each field from the Microsoft Access table is present in the HTML table. You can also 
choose to create an HTML file from the results of a Query in Microsoft Access. This way, you can 
customize the fields placed in the HTML page.

If You Have Microsoft Excel
Microsoft Excel is a useful tool for creating tables of information. The Internet Assistant for Excel can 
convert a Microsoft Excel spreadsheet into HTML format.

 Convert a Microsoft Excel document to HTML format
1. Copy the file Html.xla, from the Media\Tools\Excelia directory of this CD, to your Microsoft Excel 

Library directory.
2. Or, using Internet Explorer, go to the Authoring Software page on the Microsoft Web site, and follow 

the links to the download site for the Internet Assistant for Microsoft Excel.
http://www.microsoft.com/workshop/author
a. Copy the Internet Assistant for Excel to your Microsoft Excel Library directory.

3. Run Microsoft Excel and open Products.xls from the \Labs\Lab03.1 directory.
4. Choose Add-Ins from the Tools menu and install the Internet Assistant Add-In.
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5. Run the Internet Assistant Wizard from the Tools menu, and follow the instructions to create an HTML
table from the information on the Best Sellers sheet. 
Step 1: Create an independent HTML file.
Step 2: Set the title to Main Street Market Products, leave the Header blank, and set the description 
below the header to:

This is a brief listing of just a few of the many items that we can send you at a moment's notice. For
a more complete description, see our product catalog, or send e-mail to info@MainStMarket.com 
for more information about these and other fine food products.

Step 3: Convert the formatting of the Microsoft Excel table to HTML.
6. Save the new page as Products.htm in the root of your Web site.

Note You'll use this truncated list of products, instead of the full list of products created with the 
Internet Assistant for Access, in the remainder of the labs.

7. Test the link with Internet Explorer.
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